Amaryllo Community

Answer of your leaving message
Purchase Country: germany
Duration in-use of camera: never
Mobile device OS version ( find in app setting ) : ios and android
App version ( find in app setting ) : error message
Problem Type: not working, not moving, not connecting. just a paperweight after upgrade.
Occurrence Frequency:
Problem Description:hello, ive purchased this Cam some time ago but never used it. i tried installing to day. i was able to get it on the network. as soon as it got on the network, it asked me to upgrade the firmware before use. I clicked ok, on the latest firmware i believe, and when this was done, the app loaded. i tried clicking on play but it was giving the "camera offline message" i thought it was just an issue with the network... but the camera would not move. all i have is the blue light showing me power is on. there is absolutely no movement or tracking as there used to be before upgrade. i made sure the cable and voltage is fine. please let me know how to proceed. as of now it is a very expensive paper weight.
Thanks

by mike nasser


Dear Mike, thank you for mail. Let's check it carefully for proper actions.

1. Reboot WIFI router and camera again to check if recovered

If not helpful,

Please kindly check if the camera responses to the hardware reset.
Hardware RESET : https://www.youtube.com/watch?v=VNvftkbS__c

If it does response to the hardware reset, you may install it again.
If it does not response to the hardware reset at all and front blue led is on still, and after reboot, the camera won't do the motor auto rotation. Then, we need to do following :

Please take few minutes to try the below slowly and correctly.

Please must use this tool to check/format the SD card on PC https://www.sdcard.org/downloads/formatter_4/index.htm

Rebuild the firmware from the external SD card :
This is a manual re-build firmware procedure for your reference (recovery and cure rate is more than 90%)

Download file :
https://www.dropbox.com/s/mhl2l30tuxb0d6b/iCAM%20Pro_v421.rar?dl=0

Unplug power of camera

- Uncompress/unzip it to ROOT directory of a MicroSD card [ PC->SD ] ( one
folder (codeimg) and one file _rescue00 )
- Insert the card to the camera
- Plug power cord of it (power on). CAM will auto detect the codes in the
Card (a beep) to do the update ( blue light is on )
- Wait till front blue and green leds are blinking. (About 2-3 minutes)
- Unplug power cord
- Take card out.
- Plug power cord again and the blue led will keep blink ( waiting for
installation mode )

Installation: https://www.youtube.com/watch?v=V-j_OzXsANo , If you are successful, please erase the card for normal use.

PS – this is what you see during the process

Insert the card with unzipped files
Plug in power
Short beep ( camera detect and read the files ) in 5 seconds
After about 40 seconds Two short beeps ( writing complete )
Blue and Green lights blinking – done ( wrote in )
Unplug the power
Remove the SD and erase/delete it for future use.